GZUT_DreamPro 高速编程器手册

GZUT_New_OnePro高速编程器产品概述

1.产品图片

2.产品功能

读写25 SPI FLASH 、24 I2C EEPROM ；

3.应用范围

适用于各种用到存储芯片的场合。

4.产品特性

①兼容芯片数量多：共兼容25 SPI FLASH、24 I2C EEPROM多种存储芯片；
②烧写读取速度快：USB2.0接口，速度达到12Mb/s；芯片操作极致优化，综合烧写速度领先同类其他产品；
③全智能识别芯片：对SPI FLASH能准确识别出具体芯片型号；
④固件智能检测：固件上电、下电智能检测，节省操作时间；
⑤文件智能显示：文件源数据、溢出芯片数据、修改后的数据、非源文件数据用不同颜色字体表示，区别显示，一目了然；
⑥指定地址操作：可对芯片指定地址进行查看、烧写操作，无需整片读出或者整片重新擦除烧录，对于测试十分方便；
⑦固件外形小巧：固件体积小，十分方便携带；
⑧固件在线升级：固件升级不再难，智能一键升级保证用户固件永久最新；
⑨支持多种系统：Windows 2000、Windows XP、Windows 7、Windows8 （32、64位）；

5.技术支持：

广州市优硕微电子科技有限公司
电话：020-22320766
Copyright 2013-2018
保留所有权  All rights reserved
广州市优硕微电子科技有限公司
GuangZhou U-tek Microelectronics Technology Co.,Ltd


GZUT_DreamPro 支持芯片

GZUT_New_OnePro高速编程器支持芯片

芯片支持列表为原始发布版本的数据，最新数据请看网页
***25 SPI FLASH***
AMIC:
A25L05P A25L512 A25L010 A25L10P A25L020 A25L20P A25L040 A25L40P A25L080 A25L80P    A25L016 A25L16P A25L032
ANTRONICS：
N25S10 N25S20 N25S40 N25S80 N25S16 N25S32
ATMEL:
AT25F512 AT25F512A AT25F512B AT25F1024 AT25F1024A AT25FS010 AT25DF021 AT25F2048    AT25DF041A AT25F4096
AT25FS040 AT26F004 AT26DF081A AT25DF161 AT26DF161 AT26DF161A    AT25DF321 AT25DF321A AT26DF321 AT25DF641
EON:
EN25F05 EN25LF05 EN25P05 EN25D10 EN25F10 EN25LF10 EN25P10 EN25D20 EN25F20 EN25LF20    EN25D40 EN25F40
EN25LF40 EN25D80 EN25F80 EN25Q80 EN25T80 EN25B16 EN25B16T EN25D16    EN25F16 EN25Q16 EN25T16 EN25B32
EN25B32T EN25F32 EN25P32 EN25Q32 EN25B64 EN25B64T    EN25F64 EN25P64 EN25Q64 EN25F128 EN25Q128
ES:
ES25P10 ES25P20 ES25M40 ES25M40A ES25P40 ES25M80 ES25M80A ES25P80 ES25M16 ES25M16A    ES25P16 ES25P32
ESMT:
F25L004A F25L04UA F25L008A F25L08PA F25L016A F25L16PA F25L32PA F25L32QA
GIGADEVICE:
GD25Q512 GD25Q10 GD25Q20 GD25D40 GD25F40 GD25Q40 GD25D80 GD25F80 GD25Q80 GD25T80    GD25Q16 GD25Q32
GD25Q64 GD25Q128
MXIC:
MX25L512 MX25V512 MX25L1005 MX25L2005 MX25L4005A MX25V4005 MX25L8005 MX25V8005/06    MX25L1605D
MX25L1635D MX25L3205D MX25L3225D MX25L3235D MX25L3237D MX25L6405/06/45    MX25L12805D
NEXFLASH:
NX25P10 NX25P20 NX25P40 NX25P80 NX25P16 NX25P32
PMC:
PM25LV512 PM25LV010 PM25LV020 PM25LV040 PM25LV080B PM25LV016B
SPANSION:
S25FL004A S25FL008A S25FL016A S25FL032A S25FL064A
SST:
SST25VF512 SST25VF512A SST25VF010 SST25VF010A SST25VF020 SST25VF020A SST25VF040    SST25VF040A SST25VF040B
SST25VF080B SST25VF016B SST25VF032B SST25VF064C
ST:
M25P05A M25P10A M25PE10 M25P20 M25PE20 M25P40 M25PE40 M25P80 M25PE80 M25PX80    M25P16 M25PE16 M25PX16
M25P32 M25PX32 M25P64 M25PX64 M25P128
WINBOND:
W25P10 W25X10 W25X10A W25X10AL W25X10L W25P20 W25X20 W25X20A W25X20AL W25X20L    W25P40 W25X40
W25X40A W25X40AL W25X40L W25P80 W25X80 W25X80A W25X80AL W25X80L    W25P16 W25X16 W25P32 W25X32 W25X64

***24 EEPROM***
ATMEL:
AT24C01 AT24C01A AT24C01B AT24C02 AT24C02A AT24C02B AT24C04 AT24C04A AT24C04B    AT24C08 AT24C08A AT24C08B
AT24C16 AT24C16A AT24C16B AT24C32 AT24C32A AT24C32B    AT24C64 AT24C64A AT24C64B AT24C128-5V AT24C128-3V
AT24C128A AT24C128B AT24C256-5V    AT24C256-3V AT24C256A AT24C256B AT24C512-5V AT24C512-3V AT24C512A AT24C512B
AT24C1024 AT24C1024A AT24C1024B
CATALYST:
CAT24C01 CAT24WC01 CAT24C02 CAT24WC02 CAT24C04 CAT24WC04 CAT24C08 CAT24WC08    CAT24C16 CAT24WC16 CAT24C32
CAT24WC32 CAT24C64 CAT24WC64 CAT24C128 CAT24WC128    CAT24C256 CAT24WC256 CAT24C512 CAT24WC512 CAT24C1024
CAT24WC1024
FAIRCHILD:
FM24C01U FM24C02U FM24C03U FM24C04U FM24C05U FM24C08U FM24C09U FM24C16U FM24C17U    FM24C32U FM24C64
FM24C128 FM24C256 FM24C512 FM24C1024
HOLTEK:
HT24C01 HT24LC01 HT24C02 HT24LC02 HT24C04 HT24LC04 HT24C08 HT24LC08 HT24C16    HT24LC16 HT24C32 HT24LC32
HT24C64 HT24LC64 HT24C128 HT24LC128 HT24C256 HT24LC256    HT24C512 HT24C1024
ISSI:
IS24C01 IS24C02 IS24C04 IS24C08 IS24C16 IS24C32 IS24C64 IS24C128 IS24C256 IS24C512    IS24C1024
MICROCHIP:
24AA00 24C00 24LC00 24AA01 24AA014 24C01A 24C01C 24LC01 24LC21 24LCS21 24VL01    24AA02 24AA024 24AA025 24C02A 24C02C
24LC024 24LC025 24LC22A 24LC02B 24LCS22A    24VL02 24AA04 24C04A 24LC04 24AA08 24C08B 24LC08B 24AA16 24C16B 24LC16B
24AA32    24C32A 24LC32 24AA64 24FC64 24LC64 24AA65 24C65 24LC65 24AA128 24FC128 24LC128    24AA256 24FC256 24LC256 24AA512
24FC512 24LC512 24AA515 24FC515 24LC515 24AA1025    24AA1026 24FC1025 24FC1026 24LC1025 24LC1026
RAMTRON:
FM24C04A FM24CL04 FM24C16A FM24CL16 FM24C64 FM24CL64 FM24C256 FM24CL256 FM24C512
ROHM:
BR24C01 BR24L01 BR24C02 BR24L02 BR24C04 BR24L04 BR24C08 BR24L08 BR24C16 BR24L16    BR24C32 BR24L32 BR24C64 BR24L64
ST:
ST24C01 ST24C02 ST24C04 ST24C08 ST24C16 ST24C32 ST24C64
XICOR:
X24C01 X24C02 X24C04 X24C08 X24C16

注：
“(8b)”表示芯片作为8位存储芯片或者芯片自身为8位存储芯片；“(16b)”表示芯片作为16位存储芯片或者芯片只能作为16位存储芯片；两者都无的为8位存储芯片；


软件安装与卸载

GZUT_New_OnePro高速编程器软件的安装与卸载

1.软件的安装

双击“GZUT_OnePro_CN_32_XX.exe” (32位中文系统)弹出如下窗口：

单击“取消”将会结束本次安装，继续安装需等待2到3秒，弹出如下窗口:

选择用户权限，返回单击“上一步”，继续安装单击“下一步”，弹出如下窗口：

选择安装路径，返回单击“上一步”，继续安装单击“下一步”，弹出如下窗口：

WIN7 WIN8系统（由于部分系统权限太高，导致系统拦截了部分程序的运行）
*文件打开错误，不能读写文件
*文件拖拽失效
*没有生成桌面图标
*打开软件提示缺少文件

解决方法：
1.安装在D盘或者其他盘，不要C盘就行

直至安装到最后，弹出如下窗口：

至此安装完毕。

1. WIN8系统
安装出现1603错误导致安装失败

解决方法：
(1)、如果是Win8（主）双系统，启动到选系统的时候，选最下面的：更改默认值或选择其它选项——>选择其它选项——>疑难解答——>高级选项——>Windows启动设置—重新启动，然后选择“禁用驱动程序强制签名”；
(2)、如果不是Win8（主）的双系统，或是Win8单系统，进系统后，[Win]+[C]调出Charm菜单-更改电脑设置-设置-常规-高级启动的立即重启-疑难解答-高级选项-启动设置-重新启动，然后禁用驱动强制签名。
注：系统每次重启后默认会自动启动驱动强制签名

2.软件的卸载

方法一：

打开“控制面板”->“添加/删除程序”->“更改或删除程序”，选中“GZUT_OnePro_高速编程器”，单击“删除”即可全部彻底卸载；

方法二：

双击“GZUT_OnePro setup.exe”待其弹出欢迎修改、修复或删除程序，利用软件自身的卸载功能卸载全部组件；

方法三：

也可用其他第三方软件进行卸载，均可完全卸载；


驱动安装

GZUT_New_OnePro高速编程器驱动安装

软件安装完毕后，当编程器连接到PC机时，会弹出如下窗口：

选择“自动安装软件”，单击“下一步”弹出如下窗口：

系统会自动为编程器安装驱动程序，直至安装完毕即可：

单击“完成”即可完成驱动的安装。


自动烧录

GZUT_New_OnePro高速编程器自动烧录

功能：自动执行芯片擦除、烧录和校验

快捷键：F9

操作方法：使用快捷键或者单击“自动烧录”按钮或菜单；


芯片检测

GZUT_New_OnePro高速编程器芯片检测

功能：用于检测固件的连接状态、固件的当前模式、固件上面是否有芯片以及芯片的型号

快捷键：F5

操作方法：软件启动、固件启动和固件掉电时均会自动执行一次检测；除此之外，用户可以手动检测，

使用快捷键或者单击“芯片检测”按钮或菜单；


擦除芯片

GZUT_New_OnePro高速编程器擦除芯片

功能：擦除存储芯片内容（仅适用于FLASH芯片，对EEPROM无效）

快捷键：F4

操作方法：使用快捷键或者单击“擦除芯片”按钮或菜单；


手动烧录

GZUT_New_OnePro高速编程器芯片烧录

功能：将数据烧录至存储芯片

快捷键：F6

操作方法：使用快捷键或者单击“手动烧录”按钮或菜单；


数据校验

GZUT_New_OnePro高速编程器数据校验

功能：校验片内数据和当前文件数据是否一致

快捷键：F8

操作方法：使用快捷键或者单击“数据校验”按钮或菜单；


读芯片

GZUT_New_OnePro高速编程器读出芯片

功能：读出存储芯片内数据

快捷键：F7

操作方法：使用快捷键或者单击“读出芯片”按钮或菜单；

*保存数据：

按 “文件”菜单，选择“另储存为” 可以保存读取到缓冲区的数据


芯片查空

GZUT_New_OnePro高速编程器芯片查空

功能：检查芯片是否为空

快捷键：F3

操作方法：使用快捷键或者单击“芯片查空”按钮或菜单


固件升级

GZUT_New_OnePro高速编程器固件升级

功能：升级固件

操作方法：单击菜单“固件升级”，弹出如下窗口：

打开升级包*.utek ,单击“升级”即可全自动完成固件升级，固件升级成功后只需重新启动编程器即可；

*注1.由于部分电脑无法在烧录器切换模式时自动重新刷新USB设备导致升级失败
*注2.部分电脑需要DreamProII V1.2及以上版本，OnePro V2.1及以上版本才能成功，
(目前发现部分主板的USB2.0与USB3.0就需要如此)

解决办法如下:
1.按正常升级操作对烧录器进行升级操作
2.当提示升级失败或者进入DFU模式失败时，不要拔下烧录器，
重启电脑(注意是重新启动，请勿关闭后再启动)，此时烧录器工作指示灯会保持闪烁状态。
3.电脑开机后，重新按正常升级操作即可成功。

Copyright 2013-2018
保留所有权
广州市优硕微电子科技有限公司
All rights reserved


无标题文档

GZUT_New_OnePro高速编程器提示音设定

功能：设定鼠标操作时是否有提示音

操作方法：点击菜单设置->提示音即可


无标题文档

GZUT_New_OnePro高速编程器自动识别设定

功能：设定芯片读写操作时是否允许系统自动检测芯片

操作方法：点击菜单设置->自动识别即可


地址定位

GZUT_New_OnePro高速编程器地址定位

功能：自动定位文件地址

操作方法：单击菜单“地址定位”，弹出对话框：

输入要定位的地址，单击“确定”后者按回车即可；


数据查看

GZUT_New_OnePro高速编程器数据查看

功能：查看指定地址的文件和芯片数据

操作方法：单击菜单“数据查看”，弹出如下窗口：

输入地址，按“确定”或者回车即可；


无标题文档

GZUT_New_OnePro高速编程器数据查找

功能：自动查找指定数据

操作方法：单击菜单“数据查找”，弹出对话框：

输入查找的数据，选择以16查找方式，单击“确定”或者“下一个”即可；


文件填充

GZUT_New_OnePro高速编程器文件填充

功能：在文件的指定地址处填充指定数量的指定数据

操作方法：首先要选择编辑模式，然后单击菜单“手动烧录”，弹出如下窗口：

若选择“从文件结尾处开始填充”，则无需输入地址；

输入要填充的数据和填充长度，单击“确定”或者回车即可；


芯片填充

GZUT_New_OnePro高速编程器芯片填充

功能：在指定芯片地址中填充指定长度的指定数据

操作方法：单击菜单“芯片填充”，弹出如下窗口：

输入地址、长度和数据，单击“确定”或者回车即可；


无标题文档

GZUT_New_OnePro高速编程器时光平移

功能：指定起始地址开始烧录

操作方法：点击菜单“时光平移...”，弹出

填写要平移的起始地址(此地址将作为FLASH的0地址开始烧录)，选择要平移的文件

点击确定即可。


无标题文档

GZUT_New_OnePro高速编程器检查更新

功能：自动联网检测是否有更新版本可供升级

操作方法：点击菜单帮助->检查更新即可


无标题文档

GZUT_New_OnePro高速编程器快速反馈

功能：即时快速反馈产品使用过程中遇到的问题

操作方法：点击菜单帮助->快速反馈


GZUT_New_OnePro 脱机拷贝

Copyright 2013-2018
保留所有权  All rights reserved
广州市优硕微电子科技有限公司
GuangZhou U-tek Microelectronics Technology Co.,Ltd


无标题文档

GZUT_New_OnePro高速编程器问题及建议

1.常见问题

①USB识别错误：

可能是USB数据线过长或者USB线没有屏蔽层导致数据传输错误，致使USB无法正常识别，解决方法：更换USB线重新进行烧录；

②数据自动烧录校验无法通过：

1).芯片型号选择错误；
2).FLASH芯片在烧录前没有进行擦除芯片操作；
3).可能是USB供电不足，解决方法：将USB插到主机背面的USB端口重新烧录测试；
4).也可能是USB数据线过长或者USB线没有屏蔽层导致数据在传输过程中出错，解决方法：更换USB线重新进行烧录测试；
5).芯片损坏；

③点击“查看修改日志”无任何反应：

此种现象是由于记事本属性为未知应用程序，
解决方法：新建一个记事本，右键“属性”，将打开方式改为“记事本”；

2.使用建议：

①芯片选用规则：

数据量大，使用过程中只有读操作的适用FLASH芯片；数据量不大，使用过程中要经常进行单个地址的写操作，适用EEPROM；

②芯片烧录：

由于部分芯片在烧录前要先进行擦除操作才能正确进行烧录，加上芯片放置接触不良，市场上有些数据线质量低劣等，建议
用户在芯片烧录时使用自动烧录功能，可以有效防止因为上述因素造成的烧录错误。


版权声明

GZUT_New_OnePro高速编程器问题及建议

GZUT_New_OnePro高速编程器软件、固件及本手册所有权为广州市优硕微电子科技有限公司；
未经广州优硕微电子科技有限公司许可，任何单位和个人不得对本GZUT_New_OnePro高速编程器软件、固件及本手册进行翻版、仿造、加工等；
由于版本的升级造成的与本手册不符请以实际产品为准，同时软件、固件和手册的更新恕不另行通知；


查看固件版本

GZUT_DreamProII高速编程器查看固件版本

功能：查看固件版本信息

操作方法：单击菜单“固件版本”，弹出固件版本信息：

例如：


GZUT_DreamProII USB转串口 USB转TTL

Copyright 2013-2018
保留所有权  All rights reserved
广州市优硕微电子科技有限公司
GuangZhou U-tek Microelectronics Technology Co.,Ltd


GZUT_DreamProII 自动烧录机台连接说明

Copyright 2013-2018
保留所有权  All rights reserved
广州市优硕微电子科技有限公司
GuangZhou U-tek Microelectronics Technology Co.,Ltd


GZUT_DreamProII 25 SPI FLASH OTP 区域读写

部分25 SPI FLASH 带OTP区域 读写需要独立操作

25芯片 OTP区域 读、写、锁定方法：（OTP区域为一次性使用，只能写一次，请注意-读取无限制）

一旦锁定之后不能再次写入。

1.在“工具”菜单，进入 “OTP烧写”菜单

2.放好芯片，点“检测”键，看此芯片是否有OTP区域。

3.如果检测出此芯片有OTP区域，并且在DreamPro2编程器的支持范围，即可进行OTP区域的操作。

目前DreamPro2 编程器支持的部分OTP芯片列表：

EON:
EN25(L)F05
EN25(L)F10
EN25(L)F20
EN25(L)F40
EN25D80/Q80
EN25T80
EN25D16/Q16
EN25T16
EN25B(P)32
EN25Q32
EN25B(P)64
EN25Q64
EN25F128
EN25Q128

GIGADEVICE:
GD25D40
GD25F40
GD25LQ40
GD25D80
GD25F80
GD25LQ80
GD25T80
GD25LQ16
GD25Q32
GD25LQ32
GD25Q64
GD25LQ128

MXIC:
MX25U2033E
MX25V4035
MX25U4035
MX25L8005
MX25L8005ZM
MX25L8006E
MX25L8008E
MX25L8035E
MX25L8036E
MX25L8073E
MX25L8075E
MX25V8005
MX25V8006E
MX25V8035
MX25U8033E
MX25U8035
MX25U8035E
MX25L1605D
MX25L1608D
MX25L1606E
MX25L1608E
MX25L1633E
MX25L1635D
MX25L1635E
MX25L1636D
MX25L1636E
MX25L1673E
MX25L1675E
MX25U1635E
MX25L3205D
MX25L3206E
MX25L3208D
MX25L3208E
MX25L3225D
MX25L3235D
MX25L3235E
MX25L3236D
MX25L3237D
MX25L3273E
MX25L3275E
MX25U3235F
MX25L6405D
MX25L6406E
MX25L6408D
MX25L6408E
MX25L6435E
MX25L6436E
MX25L6445E
MX25L6465E
MX25L6473E
MX25L6475E
MX25U6435E
MX25U6435F
MX25L12805D
MX25L12835E
MX25L12835F
MX25L12836E
MX25L12839F
MX25L12845E
MX25L12865E
MX25L12873F
MX25L12875F
MX25L25835E
MX25U12835F
MX25L25635E
MX25L25635F
MX25L25639F
MX25L25735E
MX25L25735F
MX25U25635F
MX66L51235F
MX66U51235F

SPANSION:
S25FL116K
S25FL132K
S25FL164K
S25FL064K
S25FL128K
S25FL032P
S25FL064P
S25FL127S
S25FL128S
S25FL512S
S25FS128S
S25FS256S

SST:
SST25VF064C
WINBOND: x指B\D\F
W25Q20xW
W25Q40xW
W25Q80xW
W25Q16xW
W25Q32
W25Q32xW
W25Q64
W25Q64xW
W25Q128
W25Q128xW
W25Q256FV